1013 Battle Over Cities

news/2024/6/19 6:22:08 标签: c++, dfs, 图论, 算法

题目来源:PAT (Advanced Level) Practice

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

words: 

Battle 战争,战斗        vitally 至关重要的        repair 修理       enemy 敌人       respectively 分别的

题意:

给定n个顶点m条边的连通图,求当某个顶点被删除后,再将剩余的顶点连通在一起需要添加的边的条数,显然当某个顶点被删除后还是连通图则添加的边数为0条;

思路:

1. 由于n小于1000,所以使用邻接矩阵表示连通图;

2. 邻接矩阵创建完后,输入相关的边;

3. 输入要删除的点,在邻接矩阵中删除与该点相连的边,然后求图的连通分支数需要添加的边数等于连通分支数减一

4. 求连通分支数时使用DFS从任一现存顶点开始遍历除删除点外的所有点,若能从1个点出发便能遍历完所有顶点则连通分支数为1,从2两个点出发能遍历完所有顶点则连通分支数位2,依此类推;

5. 邻接矩阵占用的空间较大,在DFS()函数中采用引用方式,否则会使内存超额;

//PAT ad 1013 Battle Over Cities(25 分)
#include <iostream>
using namespace std;
#include <vector>
#define N 1005


int n,m,k;


void DFS(vector<vector<bool> > &adj,int v,bool *vis)	//以v为起点DFS进行遍历 
{
	vis[v]=true;
	for(int w=1;w<=n;w++)
		if(!vis[w]&&adj[v][w]==1)
			DFS(adj, w, vis);		
} 

void abc(vector<vector<bool> > adj,int a)	//丢失点a 
{
	int i,j;
	for(i=1;i<=n;i++)		//删除与丢书点的边 
		adj[i][a]=adj[a][i]=0;

	bool lost[n+1]={false};		//顶点是否存在数组 
	lost[a]=true;
	int connected_branch=0;
	bool vis[n+1]={false};	//访问标记数组 
	for(i=1;i<=n;i++)
	{
		
		if(!lost[i]&&(!vis[i]))	//未丢失 
		{
			DFS(adj,i,vis);
			connected_branch++;	//连通分支数
		}			 
	}	
	cout<<connected_branch-1<<endl;
 } 

int main()
{
	int i,a,b;
	cin>>n>>m>>k;
	vector<vector<bool> > adj(n+1,vector<bool> (n+1,0));
	for(i=0;i<m;i++) 	//input
	{
		cin>>a>>b;
		adj[a][b]=1;
		adj[b][a]=1; 
	} 
	
	while(k--)
	{
		cin>>a;
		abc(adj,a);
	}
	
	return 0;
}


http://www.niftyadmin.cn/n/1165105.html

相关文章

1099 Build A Binary Search Tree

题目来源&#xff1a;PAT (Advanced Level) Practice A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the nodes key.The right subtree of…

1021 Deepest Root

题目来源&#xff1a;PAT (Advanced Level) Practice A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is ca…

1076 Forwards on Weibo

题目来源&#xff1a;PAT (Advanced Level) Practice Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user …

1003 Emergency

题目来源&#xff1a;PAT (Advanced Level) Practice As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length…

1072 Gas Station

题目来源&#xff1a;PAT (Advanced Level) Practice A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses a…

1057 Stack

题目来源&#xff1a;PAT (Advanced Level) Practice Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (de…

1105 Spiral Matrix (25 分)

题目来源&#xff1a;PAT (Advanced Level) Practice This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a cl…

1046 Shortest Distance

题目来源&#xff1a;PAT (Advanced Level) Practice The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits. Input Specification: Each input file contains o…